We have investigated and confirmed the notices imported from Sell2Wales are legitimate opportunities that were published on the portal. We have requested confirmation from Sell2Wales as to why so many were published on Feb 26 with some deadlines in the past and await their confirmation. We continue to ensure you are notified daily of any relevant tenders that are published across all procurement portals in the last 24 hours.
Posted Feb 27, 2025 - 14:26 GMT
Investigating
As part of our daily comprehensive collection of procurement notices, we have identified an abnormal volume of records were published yesterday on portals such as Sell2Wales and Public Contracts Scotland. With many of these records, it appears the tender submission date is either in the past or set with a very short deadline. We are currently investigating why these notices were published on these portals yesterday and will continue to keep you updated.
Posted Feb 27, 2025 - 09:42 GMT
This incident affected: Email alert notifications.